您所在的位置:cisco专区 > 思科技术 > VPN设置实例(运营商为移动公司)

VPN设置实例(运营商为移动公司)

2006-07-04 11:50 Cisco.com 字号:T | T
一键收藏,随时查看,分享好友!

AD:

一、物理连接
运营商移动公司光纤过来-----协议转换器---------协议转换器TX1口通过直通线-------- CISCO2621  FastEthernet0/1口---------CISCO2621 FastEthernet0/0口通过直通线------华为6506的第九口上。
二、地址情况
      移动分配给我信息中心的广域网地址空间为221.155.154.80---83/30,其中,221.155.154.81/30为 CMNET端口地址,我方广域网地址为:221.155.154.82/30,即CISCO2621 FastEthernet0/1端口地址。
移动分配给各个GPRS上网卡地址空间为10.222.180.0/26,即可用地址为10.222.180.1-62/26,地址与GPRS网卡绑定。上网卡经过特殊处理,拨号上网后即获得上述地址空间中的一个,不会有其它地址,也不会上CMNET。
移动提供的GRE目标地址为211.138.27.20。
我公司内网服务器组为一个VLAN,子网可用地址空间为192.67.224.161-190/27,其中服务器已经用了192.67.224.166-171/27,测试服务器IP地址为192.67.224.169/27。
三、网络建设目的和方法
      目的:各个用户通过GPRS网卡上网访问我们的服务器,例如,可以FTP://10.67.224.169。
方法:将CISCO2621 FastEthernet0/0作为内网端口接入内网,地址为10.67.224.180/27, FastEthernet0/1作为外网端口,设置一个GRE通道,源地址为221.155.154.82,目标地址为:211.138.27.20。
四、CISCO2621配置



User Access Verification
Password: �
Router>
Router>en
Password:
Router#
Router#sh run
Building configuration...
Current configuration : 788 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$obD7$usViXsqZ43r9u1Eo/A3UY/
enable password relay
!
ip subnet-zero
!
!
ip ftp username annymous
!
!
!
!
interface Tunnel0
ip address 10.0.0.6 255.255.255.248
tunnel source 221.155.154.82
tunnel destination 211.138.27.20
!
interface FastEthernet0/0
ip address 192.67.224.180 255.255.255.224
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 221.155.154.82 255.255.255.252
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 221.155.154.82
ip route 10.222.180.0 255.255.255.192 Tunnel0
ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
password relay
login
!
no scheduler allocate
end
Router#
五、服务器设置
在相应服务器上执行如下命令:

route add 10.222.180.0 mask 255.255.255.192   192.67.224.180   metric 1

(责任编辑:城尘 68476636-8003)




分享到:

栏目热门

更多>>

  1. 无线路由器怎么改密码? 手把手教你学
  2. 2019年云计算市场,运营商准备好了!

热点职位

更多>>

热点专题

更多>>

读书

网络管理员考试考前冲刺预测卷及考点解析
本书依据最新版《网络管理员考试大纲》的考核要求,深入研究了历年网络管理员考试试题的命题风格和试题结构,对考查的知识点进行

51CTO旗下网站

领先的IT技术网站 51CTO 中国首个CIO网站 CIOage 中国首家数字医疗网站 HC3i 51CTO学院