|
|
|
|
移动端

一个正常使用的ADSL配置

一个正常使用的ADSL配置

作者:来源:cisco.com|2006-07-04 09:10

开发者盛宴来袭!7月28日51CTO首届开发者大赛决赛带来技术创新分享

vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface Ethernet0/0
no ip address
full-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
interface Ethernet0/1
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
full-duplex
no cdp enable
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 2
no cdp enable
ppp authentication pap callin
ppp pap sent-username fmapdof password 0 f535120
!
ip nat inside source list 1 interface Dialer1 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
access-list 1 permit any
dialer-list 2 protocol ip permit

需要注意的就是 ip tcp adjust-mss 1452 调整tcp最大分段大小以满足PPPOE下的MTU
因为pppoe下 实际的数据段只能为1500-8(ppp的头)=1492,1492再减去TCP和IP头各20等于1452,也就是说为了避免2层上不停的分割数据包,适应某些应用如MSN,同时加快传输.

(责任编辑: 51CTO.com TEL:010-68476606)

点赞 0
分享:
大家都在看
猜你喜欢

热门职位+更多

读 书 +更多

网管员必读——网络基础(第2版)

本书是在《网管员必读—网络基础》(第1版)基础上修改而成的。全书共分9章,分别介绍计算机网络概述(修改)、数制(新增)、网络通信基础...

订阅51CTO邮刊

点击这里查看样刊

订阅51CTO邮刊